Get in touch
Back
Degraded

Financial Insights is partially down

Started 8 Jun at 03:58pm EDT, resolved 8 Jun at 05:05pm EDT.

Planworth API
Resolved

The issue has been resolved

Posted 8 Jun at 05:05pm EDT.
Created

Changes made to the sliders in the Financial Insights dashboard generate errors

Posted 8 Jun at 03:58pm EDT.